Senator Sessions says he may be open to a compromise gun measure

This is an archived article and the information in the article may be outdated. Please look at the time stamp on the story to see when it was last updated.

WASHINGTON (CNN) — Sen. Jeff Sessions said Sunday that he would consider compromise gun legislation being hammered out by moderate Republican Sen. Susan Collins of Maine, but has concerns about the constitutional rights of people placed on the federal terrorist watch list.

“The problem is, you have got indications on this list of people who might be involved in terrorism,” Sessions told CNN’s Dana Bash on “State of the Union.” “And we need to keep a list of that, need to do the best we can to monitor those people, so that they don’t become an active terrorist person. But a lot of people may be wrongly on the list. In fact, I’m sure there are a lot of people on that list that shouldn’t be on it.”

Senate Republicans have expressed broad concerns about the quality and accuracy of using the federal terrorist watchlist as a tool to bar suspected terrorists from buying guns. It comes as senators are preparing to vote Monday on a series of measures that would limit access to guns, in response to the Orlando terror attack.

But Sessions, one of the chamber’s most conservative Republicans, said he may be open to a compromise gun measure being put together by Collins, which would limit gun sales to a narrower grouping of people identified as possible terrorists.

“Susan is so careful about those things. And she’s worked really hard to figure out the differences in various lists and what kind of proof it takes to get on that list,” he said. “So, I would be willing to listen to what she said. I am open to the details, Dana. I agree that, somehow, some way, we should be able to make this work.”

Notice: you are using an outdated browser. Microsoft does not recommend using IE as your default browser. Some features on this website, like video and images, might not work properly. For the best experience, please upgrade your browser.